ネリモノ系

Twitter: https://twitter.com/msbtjp

というわけで

debian lenny で uim, uim-anthy の依存関係がぶっ壊れてたので
とりあえず対処したよ!


source.list を Etch用 にしてやって、

sudo aptitude install uim uim-anthy

で、uim, uim-anthy だけをダウングレード。

sudo aptitude hold uim uim-anthy

としてから、
source.list を Lenny用 に戻してやる。
後は一応、

sudo aptitude update; sudo aptitude upgrade

これでとりあえず日本語入力も復活して、まともに生活できるようになったよ!


追記:
なんか aptitude hold PackageName じゃ上手く hold できてなかったらしいので、

sudo echo uim hold | sudo dpkg --set-selections
sudo echo uim-anthy hold | sudo dpkg --set-selections
sudo echo libcanna1g hold | sudo dpkg --set-selections

に変更した。